Wszystkie narzędzia do kodowania
Darmowe narzędzia działające w przeglądarce do Base64 i wszystkich innych popularnych kodowań danych binarnych na tekst, a także konwertery i narzędzia do obrazów i plików. Nic, co wprowadzisz, nie jest przesyłane na serwer.
Narzędzia Base64
Kodowanie i dekodowanie Base64Kodowanie i dekodowanie tekstu lub plików w Base64 i Base64URL
Kodowanie Base64Kodowanie tekstu i plików do Base64 z wyborem zestawu znaków, dopełnienia i zawijania wierszy
Dekodowanie Base64Dekodowanie Base64 na tekst lub hex z wyborem zestawu znaków i tolerancją błędów formatu
Base64URLBase64 bezpieczny dla URL (RFC 4648, sekcja 5) dla JWT, OAuth i adresów URL
Walidator Base64Wykrywanie nieprawidłowych znaków i błędów dopełnienia w Base64 i Base64URL
Base64 na HexKonwersja skrótów, kluczy i podpisów z Base64 na zapis szesnastkowy
Hex na Base64Konwersja skrótów, kluczy i odcisków palców z hex na Base64
Dekoder JWTDekodowanie nagłówka i oświadczeń JWT, sprawdzanie ważności i weryfikacja podpisu
Generator Basic AuthTworzenie i dekodowanie nagłówków HTTP Basic Authorization
Generator data URITworzenie i analiza data URI w Base64 lub kodowaniu procentowym
Kodowania Base-N
Binarny (Base2)Tekst na kod binarny i z powrotem, 8 bitów na bajt
Ósemkowy (Base8)Tekst na ósemkowe wartości bajtów i z powrotem, od 000 do 377
Dziesiętny (Base10)Tekst na dziesiętne wartości bajtów (kody ASCII) i z powrotem
Hex (Base16)Tekst na hex i hex na tekst, z separatorami i prefiksami
Base32Base32 według RFC 4648, Base32hex, Crockford i z-base-32
Base32hexBase32 z RFC 4648 z sortowalnym alfabetem 0-9 A-V
Crockford Base32Czytelny Base32 bez I, L, O i U, z wyrozumiałym dekoderem
z-base-32Przyjazny dla ludzi Base32 z małych liter, bez dopełnienia
Base36Cyfry i a-z, kodowanie dużych liczb bez rozróżniania wielkości liter
Base45Base45 według RFC 9285 dla kodów QR i zaświadczeń COVID
Base58Base58 w wariantach Bitcoin, Flickr i Ripple, z opcjonalnym Base58Check
Base58CheckBase58 z sumą kontrolną z podwójnego SHA-256, jak w adresach Bitcoin
Base62Tylko cyfry i litery, do krótkich linków i identyfikatorów
Base85Base85 z zestawem znaków RFC 1924, jak w Git i Pythonie
Ascii85Ascii85 Adobe ze skrótem z i opcjonalnymi ogranicznikami
Z85Base85 ZeroMQ (RFC 32), bezpieczny w łańcuchach w kodzie
Base91basE91 autorstwa Joachima Henkego, zwarte kodowanie ASCII
UuencodeKodowanie Unix-to-Unix z wierszami begin i end
XxencodeWariant uuencode z alfabetem złożonym z liter i cyfr
Konwertery
Wszystkie kodowaniaKodowanie tekstu we wszystkich formatach naraz i porównanie wyników
Wykrywacz kodowaniaRozpoznawanie nieznanego zakodowanego ciągu i podgląd zdekodowanych danych
Konwerter kodowańKonwersja między Base64, Base58, Base32, hex i innymi kodowaniami
Base58 na HexDekodowanie adresów, kluczy i skrótów Base58 do bajtów hex
Hex na Base58Kodowanie bajtów hex, kluczy i skrótów w Base58
Własny alfabetKodowanie i dekodowanie dowolnym alfabetem jako duża liczba lub w grupach bitów
Konwerter systemów liczbowychZapis dwójkowy, ósemkowy, dziesiętny, hex, Base36 i Base62 dowolnej liczby całkowitej
Narzędzia do obrazów
Obraz na Base64Dowolny obraz jako data URI, znacznik img, CSS lub Markdown
Base64 na obrazDekodowanie Base64 lub data URI do podglądu i pliku graficznego do pobrania
PNG na Base64Bezstratny PNG z przezroczystością jako Base64 data:image/png
JPG na Base64Zdjęcia JPEG jako Base64 data:image/jpeg z regulacją jakości
WebP na Base64Kompaktowe obrazy WebP jako Base64 data:image/webp
GIF na Base64Statyczne i animowane GIF-y jako Base64 data:image/gif
SVG na Base64Grafika wektorowa SVG jako Base64 data:image/svg+xml
BMP na Base64Mapy bitowe BMP jako Base64 z opcjonalną konwersją na PNG
ICO na Base64Ikony favicon i pliki .ico jako data URI w Base64
AVIF na Base64Obrazy AVIF z kompresją AV1 jako Base64 data:image/avif
TIFF na Base64Skany TIFF i obrazy do druku jako tekst Base64
Base64 na PNGZapis ciągów Base64 lub data:image/png jako plików PNG z zachowaniem przezroczystości
Base64 na JPGDekodowanie Base64 do zdjęcia .jpg z suwakiem jakości przy konwersji
Base64 na WebPDekodowanie WebP z Base64 lub konwersja obrazów Base64 na mniejsze pliki WebP
Base64 na GIFZapis GIF-ów z Base64 z zachowaniem animacji lub konwersja obrazów na GIF
Base64 na SVGDekodowanie ikon i grafik SVG z Base64 z powrotem do plików .svg
Base64 na BMPDekodowanie Base64 do .bmp lub konwersja obrazów na 32-bitowe bitmapy
Base64 na ICODekodowanie ikon z Base64 lub zamiana obrazów Base64 na pliki favicon.ico
Base64 na AVIFDekodowanie obrazów AVIF z Base64 lub konwersja na AVIF, jeśli jest obsługiwana
Base64 na TIFFZapis skanów z Base64 jako TIFF lub konwersja obrazów na nieskompresowany TIFF
Narzędzia do plików
Plik na Base64Kodowanie dowolnego pliku do 100 MB jako czysty Base64 lub data URI
Base64 na plikDekodowanie Base64 do pliku z wykrywaniem typu i podglądem
PDF na Base64Kodowanie plików PDF jako Base64 lub data URI z podglądem dokumentu
Base64 na PDFDekodowanie Base64 do PDF z podglądem w przeglądarce i pobieraniem
Audio na Base64Kodowanie MP3, WAV, OGG i innych plików audio jako Base64 lub data URI
Base64 na audioDekodowanie Base64 do MP3, WAV, OGG, FLAC lub M4A z odtwarzaniem