Alle kodingsverktøy
Gratis nettleserbaserte verktøy for Base64 og alle andre vanlige kodinger fra binærdata til tekst, pluss konvertere og verktøy for bilder og filer. Ingenting du skriver inn, lastes opp.
Base64-verktøy
Base64-koding og -dekodingKod og dekod Base64 og Base64URL for tekst og filer
Base64-kodingKod tekst eller filer til Base64 med valg for tegnsett, utfylling og linjebryting
Base64-dekodingDekod Base64 til tekst eller hex med valgfritt tegnsett og tolerant innlesing
Base64URLURL-sikker Base64 (RFC 4648, avsnitt 5) for JWT, OAuth og URL-er
Base64-validatorSjekk Base64- og Base64URL-strenger for ugyldige tegn og utfyllingsfeil
Base64 til hexKonverter Base64-hasher, nøkler og signaturer til heksadesimalt
Hex til Base64Konverter hex-hasher, nøkler og fingeravtrykk til Base64
JWT-dekoderDekod JWT-header og claims, sjekk utløp og verifiser signaturer
Basic Auth-generatorLag eller dekod HTTP Basic Authorization-headere
Data URI-generatorLag og undersøk data:-URI-er med Base64 eller prosentkoding
Base-N-kodinger
Binær (Base2)Tekst til binær og binær til tekst, 8 bit per byte
Oktal (Base8)Tekst til oktale byteverdier og tilbake, 000 til 377
Desimal (Base10)Tekst til desimale byteverdier (ASCII-koder) og tilbake
Hex (Base16)Tekst til hex og hex til tekst, med skilletegn og prefikser
Base32Base32 etter RFC 4648, Base32hex, Crockford og z-base-32
Base32hexBase32 etter RFC 4648 med det sorterbare alfabetet 0-9 A-V
Crockford Base32Lesbar Base32 uten I, L, O og U, med en tolerant dekoder
z-base-32Menneskevennlig Base32 med små bokstaver og uten utfylling
Base36Sifre og a-z, en stortallskoding som ignorerer bokstavstørrelse
Base45Base45 etter RFC 9285 for QR-koder og koronasertifikater
Base58Base58 med Bitcoin-, Flickr- og Ripple-alfabet og valgfri Base58Check
Base58CheckBase58 med dobbel SHA-256-kontrollsum, som i Bitcoin-adresser
Base62Bare sifre og bokstaver, for korte URL-er og ID-er
Base85Base85 med tegnsettet fra RFC 1924, som i Git og Python
Ascii85Adobe Ascii85 med z-forkortelsen og valgfrie avgrensere
Z85ZeroMQ Base85 (RFC 32), trygg i strenger i kildekode
Base91basE91 av Joachim Henke, en kompakt ASCII-koding
UuencodeUnix-to-Unix-koding med begin- og end-linjer
XxencodeUuencode-variant med et alfabet av bokstaver og sifre
Konverteringsverktøy
Alle kodingerKod tekst i alle formater samtidig og sammenlign resultatene
KodingsgjenkjennerIdentifiser en ukjent kodet streng og forhåndsvis de dekodede dataene
KodingskonverterKonverter mellom Base64, Base58, Base32, hex og andre kodinger
Base58 til hexDekod Base58-adresser, -nøkler og -hasher til hex-byte
Hex til Base58Kod hex-byte, nøkler og hasher som Base58
Egendefinert alfabetKod og dekod med et hvilket som helst alfabet, som stort tall eller i bitgrupper
TallsystemkonverterBinær, oktal, desimal, hex, Base36 og Base62 for alle heltall
Bildeverktøy
Bilde til Base64Kod et hvilket som helst bilde som data URI, img-tagg, CSS eller Markdown
Base64 til bildeDekod Base64 eller data URI-er til en forhåndsvisning og en bildefil du kan laste ned
PNG til Base64Tapsfri PNG med gjennomsiktighet som data:image/png Base64
JPG til Base64JPEG-bilder som data:image/jpeg Base64 med kvalitetskontroll
WebP til Base64Kompakte WebP-bilder som data:image/webp Base64
GIF til Base64Statiske og animerte GIF-er som data:image/gif Base64
SVG til Base64SVG-vektorgrafikk som data:image/svg+xml Base64
BMP til Base64BMP-bilder som Base64, med valgfri konvertering til PNG
ICO til Base64Favicons og .ico-filer som Base64-data URI-er
AVIF til Base64AV1-komprimerte AVIF-bilder som data:image/avif Base64
TIFF til Base64TIFF-skanninger og trykkbilder som Base64-tekst
Base64 til PNGLagre Base64 eller data:image/png-strenger som PNG-filer, med gjennomsiktighet
Base64 til JPGDekod Base64 til et .jpg-foto, med kvalitetsinnstilling ved konvertering
Base64 til WebPDekod Base64-WebP eller konverter Base64-bilder til mindre WebP-filer
Base64 til GIFLagre Base64-GIF-er med animasjonen intakt, eller konverter bilder til GIF
Base64 til SVGDekod Base64-kodede SVG-ikoner og -grafikk tilbake til .svg-filer
Base64 til BMPDekod Base64 til .bmp eller konverter bilder til 32-bits bitmaper
Base64 til ICODekod Base64-ikoner eller gjør Base64-bilder om til favicon.ico-filer
Base64 til AVIFDekod Base64-AVIF-bilder, eller konverter til AVIF der det støttes
Base64 til TIFFLagre Base64-skanninger som TIFF eller konverter bilder til ukomprimert TIFF
Filverktøy
Fil til Base64Kod alle filer opptil 100 MB som ren Base64 eller data URI
Base64 til filDekod Base64 til en fil med typegjenkjenning og forhåndsvisning
PDF til Base64Kod PDF-er som Base64 eller data URI, med forhåndsvisning av dokumentet
Base64 til PDFDekod Base64 til PDF, vis den i nettleseren og last den ned
Lyd til Base64Kod MP3, WAV, OGG og annen lyd som Base64 eller data URI
Base64 til lydDekod Base64 til MP3, WAV, OGG, FLAC eller M4A og spill det av