Todas las herramientas de codificación
Herramientas gratuitas en el navegador para Base64 y todas las demás codificaciones habituales de binario a texto, además de conversores y herramientas de imagen y archivos. Nada de lo que introduces se sube.
Herramientas Base64
Codificar y decodificar Base64Codifica y decodifica texto o archivos en Base64 y Base64URL
Codificar Base64Codifica texto o archivos en Base64 con codificación, relleno y ajuste de línea
Decodificar Base64Decodifica Base64 a texto o hexadecimal, con elección de codificación y entrada tolerante
Base64URLBase64 seguro para URL (RFC 4648, sección 5) para JWT, OAuth y URL
Validador Base64Detecta caracteres no válidos y errores de relleno en cadenas Base64 y Base64URL
Base64 a hexadecimalConvierte hashes, claves y firmas en Base64 a hexadecimal
Hexadecimal a Base64Convierte hashes, claves y huellas en hexadecimal a Base64
Decodificador JWTDecodifica encabezado y claims de un JWT, revisa la caducidad y la firma
Generador de Basic AuthCrea o decodifica encabezados HTTP Basic Authorization
Generador de data URICrea y examina data URI con Base64 o codificación porcentual
Codificaciones Base-N
Binario (Base2)Texto a binario y binario a texto, 8 bits por byte
Octal (Base8)Texto a valores de byte en octal y viceversa, de 000 a 377
Decimal (Base10)Texto a valores de byte decimales (códigos ASCII) y viceversa
Hexadecimal (Base16)Texto a hexadecimal y hexadecimal a texto, con separadores y prefijos
Base32Base32 RFC 4648, Base32hex, Crockford y z-base-32
Base32hexBase32 de RFC 4648 con el alfabeto ordenable 0-9 A-V
Crockford Base32Base32 legible sin I, L, O ni U, con un decodificador tolerante
z-base-32Base32 en minúsculas pensado para personas, sin relleno
Base36Dígitos y a-z, codificación de número grande sin distinción de mayúsculas
Base45Base45 RFC 9285 para códigos QR y certificados COVID
Base58Base58 de Bitcoin, Flickr y Ripple, con Base58Check opcional
Base58CheckBase58 con suma de verificación doble SHA-256, como en las direcciones Bitcoin
Base62Solo dígitos y letras, para URL cortas e ID
Base85Base85 con el juego de caracteres de RFC 1924, como en Git y Python
Ascii85Ascii85 de Adobe con la abreviatura z y delimitadores opcionales
Z85Base85 de ZeroMQ (RFC 32), seguro en cadenas de código fuente
Base91basE91 de Joachim Henke, una codificación ASCII compacta
UuencodeCodificación Unix-to-Unix con líneas begin y end
XxencodeVariante de uuencode con un alfabeto de letras y dígitos
Conversores
Todas las codificacionesCodifica un texto en todos los formatos a la vez y compara los resultados
Detector de codificaciónIdentifica una cadena codificada desconocida y ve los datos decodificados
Conversor de codificacionesConvierte entre Base64, Base58, Base32, hexadecimal y otras codificaciones
Base58 a hexadecimalDecodifica direcciones, claves y hashes Base58 a bytes en hexadecimal
Hexadecimal a Base58Codifica en Base58 bytes, claves y hashes en hexadecimal
Alfabeto personalizadoCodifica y decodifica con cualquier alfabeto: número grande o grupos de bits
Conversor de bases numéricasBinario, octal, decimal, hexadecimal, Base36 y Base62 para cualquier entero
Herramientas de imagen
Imagen a Base64Codifica cualquier imagen como data URI, etiqueta img, CSS o Markdown
Base64 a imagenDecodifica Base64 o data URI en una vista previa y un archivo de imagen descargable
PNG a Base64PNG sin pérdida y con transparencia como Base64 data:image/png
JPG a Base64Fotos JPEG como Base64 data:image/jpeg con control de calidad
WebP a Base64Imágenes WebP compactas como Base64 data:image/webp
GIF a Base64GIF estáticos y animados como Base64 data:image/gif
SVG a Base64Gráficos vectoriales SVG como Base64 data:image/svg+xml
BMP a Base64Mapas de bits BMP como Base64, con conversión opcional a PNG
ICO a Base64Favicons y archivos .ico como data URI en Base64
AVIF a Base64Imágenes AVIF comprimidas con AV1 como Base64 data:image/avif
TIFF a Base64Escaneos e imágenes de impresión TIFF como texto Base64
Base64 a PNGGuarda cadenas Base64 o data:image/png como archivos PNG, transparencia incluida
Base64 a JPGDecodifica Base64 en una foto .jpg, con control de calidad para las conversiones
Base64 a WebPDecodifica WebP en Base64 o convierte imágenes Base64 en archivos WebP más ligeros
Base64 a GIFGuarda GIF en Base64 con la animación intacta o convierte imágenes a GIF
Base64 a SVGDecodifica iconos y gráficos SVG en Base64 y recupera los archivos .svg
Base64 a BMPDecodifica Base64 en .bmp o convierte imágenes en mapas de bits de 32 bits
Base64 a ICODecodifica iconos en Base64 o convierte imágenes Base64 en archivos favicon.ico
Base64 a AVIFDecodifica imágenes AVIF en Base64 o convierte a AVIF si tu navegador lo permite
Base64 a TIFFGuarda escaneos en Base64 como TIFF o convierte imágenes a TIFF sin comprimir
Herramientas de archivos
Archivo a Base64Codifica cualquier archivo de hasta 100 MB como Base64 puro o data URI
Base64 a archivoDecodifica Base64 a un archivo con detección de tipo y vista previa
PDF a Base64Codifica PDF como Base64 o data URI, con vista previa del documento
Base64 a PDFDecodifica Base64 a PDF, visualízalo en el navegador y descárgalo
Audio a Base64Codifica MP3, WAV, OGG y otros audios como Base64 o data URI
Base64 a audioDecodifica Base64 a MP3, WAV, OGG, FLAC o M4A y reprodúcelo