Todas as ferramentas de codificação
Ferramentas gratuitas no navegador para Base64 e todas as outras codificações comuns de binário para texto, além de conversores e ferramentas de imagem e arquivo. Nada do que você insere é enviado.
Ferramentas Base64
Codificar e decodificar Base64Codifique e decodifique texto ou arquivos em Base64 e Base64URL
Codificar em Base64Codifique texto ou arquivos em Base64 com charset, preenchimento e quebra de linha
Decodificar Base64Decodifique Base64 para texto ou hex, com escolha de charset e tolerância a erros
Base64URLBase64 seguro para URL (RFC 4648, seção 5) para JWT, OAuth e URLs
Validador Base64Encontre caracteres inválidos e erros de preenchimento em Base64 e Base64URL
Base64 para HexConverta hashes, chaves e assinaturas de Base64 para hexadecimal
Hex para Base64Converta hashes, chaves e impressões digitais de hex para Base64
Decodificador JWTLeia cabeçalho e declarações do JWT, confira a expiração e verifique assinaturas
Gerador de Basic AuthGere ou decodifique cabeçalhos HTTP Basic Authorization
Gerador de data URICrie e inspecione URIs data: com Base64 ou codificação percentual
Codificações Base-N
Binário (Base2)Texto para binário e binário para texto, 8 bits por byte
Octal (Base8)Texto para valores de byte em octal e vice-versa, de 000 a 377
Decimal (Base10)Texto para valores de byte decimais (códigos ASCII) e vice-versa
Hex (Base16)Texto para hex e hex para texto, com separadores e prefixos
Base32Base32 da RFC 4648, Base32hex, Crockford e z-base-32
Base32hexBase32 da RFC 4648 com o alfabeto ordenável 0-9 A-V
Crockford Base32Base32 legível sem I, L, O e U, com decodificador tolerante
z-base-32Base32 em minúsculas pensado para pessoas, sem preenchimento
Base36Dígitos e a-z, codificação por número grande sem distinção de maiúsculas
Base45Base45 da RFC 9285 para QR codes e certificados COVID
Base58Base58 com alfabetos Bitcoin, Flickr e Ripple e Base58Check opcional
Base58CheckBase58 com soma de verificação SHA-256 dupla, como nos endereços Bitcoin
Base62Só dígitos e letras, para URLs curtas e IDs
Base85Base85 com o conjunto de caracteres RFC 1924, como no Git e no Python
Ascii85Ascii85 da Adobe com o atalho z e delimitadores opcionais
Z85Base85 do ZeroMQ (RFC 32), seguro em strings no código-fonte
Base91basE91 de Joachim Henke, uma codificação ASCII compacta
UuencodeCodificação Unix-to-Unix com linhas begin e end
XxencodeVariante do uuencode com alfabeto de letras e dígitos
Conversores
Todas as codificaçõesCodifique texto em todos os formatos de uma vez e compare os resultados
Detector de codificaçãoIdentifique uma string codificada desconhecida e veja os dados decodificados
Conversor de codificaçõesConverta entre Base64, Base58, Base32, hex e outras codificações
Base58 para HexDecodifique endereços, chaves e hashes Base58 em bytes hex
Hex para Base58Codifique bytes hex, chaves e hashes em Base58
Alfabeto personalizadoCodifique e decodifique com qualquer alfabeto, como número grande ou em grupos de bits
Conversor de bases numéricasBinário, octal, decimal, hex, Base36 e Base62 para qualquer número inteiro
Ferramentas de imagem
Imagem para Base64Codifique qualquer imagem como data URI, tag img, CSS ou Markdown
Base64 para imagemDecodifique Base64 ou data URIs em uma prévia e em um arquivo de imagem para baixar
PNG para Base64PNG sem perdas e com transparência como Base64 data:image/png
JPG para Base64Fotos JPEG como Base64 data:image/jpeg com controle de qualidade
WebP para Base64Imagens WebP compactas como Base64 data:image/webp
GIF para Base64GIFs estáticos e animados como Base64 data:image/gif
SVG para Base64Gráficos vetoriais SVG como Base64 data:image/svg+xml
BMP para Base64Bitmaps BMP em Base64, com conversão opcional para PNG
ICO para Base64Favicons e arquivos .ico como data URIs em Base64
AVIF para Base64Imagens AVIF comprimidas com AV1 como Base64 data:image/avif
TIFF para Base64Digitalizações e imagens TIFF para impressão como texto Base64
Base64 para PNGSalve strings Base64 ou data:image/png como arquivos PNG, com transparência
Base64 para JPGDecodifique Base64 em uma foto .jpg, com controle de qualidade nas conversões
Base64 para WebPDecodifique WebP em Base64 ou converta imagens Base64 em arquivos WebP menores
Base64 para GIFSalve GIFs em Base64 com a animação intacta ou converta imagens em GIF
Base64 para SVGDecodifique ícones e gráficos SVG em Base64 de volta em arquivos .svg
Base64 para BMPDecodifique Base64 em .bmp ou converta imagens em bitmaps de 32 bits
Base64 para ICODecodifique ícones em Base64 ou transforme imagens Base64 em arquivos favicon.ico
Base64 para AVIFDecodifique imagens AVIF em Base64 ou converta para AVIF onde houver suporte
Base64 para TIFFSalve digitalizações em Base64 como TIFF ou converta imagens em TIFF sem compressão
Ferramentas de arquivo
Arquivo para Base64Codifique qualquer arquivo de até 100 MB como Base64 puro ou data URI
Base64 para arquivoDecodifique Base64 em arquivo com detecção de tipo e prévia
PDF para Base64Codifique PDFs como Base64 ou data URI, com prévia do documento
Base64 para PDFDecodifique Base64 em PDF, visualize no navegador e baixe
Áudio para Base64Codifique MP3, WAV, OGG e outros áudios como Base64 ou data URI
Base64 para áudioDecodifique Base64 em MP3, WAV, OGG, FLAC ou M4A e ouça