エンコードツール一覧

Base64 をはじめ、よく使われるバイナリ・テキスト変換方式すべてに対応した、ブラウザで動く無料ツールです。変換ツールや画像・ファイル用のツールもそろっています。入力した内容がアップロードされることはありません。

Base64 ツール

Base-N エンコード

2進数(Base2)テキストと2進数を相互変換、1 バイトを 8 ビットで表記 8進数(Base8)テキストと8進数のバイト値(000~377)を相互変換 10進数(Base10)テキストと10進数のバイト値(ASCII コード)を相互変換 16進数(Base16)区切り文字やプレフィックスを指定してテキストと16進数を相互変換 Base32RFC 4648 の Base32、Base32hex、Crockford、z-base-32 に対応 Base32hex並び順を保つ 0-9 A-V アルファベットの RFC 4648 Base32 Crockford Base32I、L、O、U を除いた読みやすい Base32、入力ミスに寛容なデコーダー付き z-base-32パディングなしの、人が扱いやすい小文字の Base32 Base36数字と a-z を使う、大文字と小文字を区別しない多倍長整数エンコード Base45QR コードや COVID 証明書向けの RFC 9285 Base45 Base58Bitcoin・Flickr・Ripple 版の Base58。Base58Check にも対応 Base58CheckBitcoin アドレスと同じ、ダブル SHA-256 チェックサム付きの Base58 Base62数字と英字だけの、短縮 URL や ID 向けエンコード Base85Git や Python と同じ RFC 1924 文字セットの Base85 Ascii85z 表記と区切り記号に対応した Adobe の Ascii85 Z85ソースコードの文字列でも安全な ZeroMQ の Base85(RFC 32) Base91Joachim Henke によるコンパクトな ASCII エンコード basE91 Uuencodebegin 行と end 行付きの Unix-to-Unix エンコード Xxencode英字と数字中心のアルファベットを使う uuencode の派生形式

変換ツール

画像ツール

画像 → Base64あらゆる画像を data URI、img タグ、CSS、Markdown に変換 Base64 → 画像Base64 や data URI をデコードして画像をプレビュー・ダウンロード PNG → Base64透過付きのロスレス PNG を data:image/png の Base64 に JPG → Base64品質を調整して JPEG 写真を data:image/jpeg の Base64 に WebP → Base64コンパクトな WebP 画像を data:image/webp の Base64 に GIF → Base64静止画・アニメーション GIF を data:image/gif の Base64 に SVG → Base64SVG ベクター画像を data:image/svg+xml の Base64 に BMP → Base64BMP ビットマップを Base64 に(PNG への変換も可能) ICO → Base64ファビコンや .ico ファイルを Base64 の data URI に AVIF → Base64AV1 圧縮の AVIF 画像を data:image/avif の Base64 に TIFF → Base64TIFF のスキャン画像や印刷用画像を Base64 テキストに Base64 → PNGBase64 や data:image/png 文字列を透過付きの PNG ファイルとして保存 Base64 → JPGBase64 を .jpg の写真にデコード。変換時は品質スライダーで調整可能 Base64 → WebPBase64 の WebP をデコード、または画像を軽量な WebP に変換 Base64 → GIFBase64 の GIF をアニメーションごと保存、または画像を GIF に変換 Base64 → SVGBase64 の SVG アイコンやグラフィックを .svg ファイルに戻す Base64 → BMPBase64 を .bmp にデコード、または画像を 32 ビットビットマップに変換 Base64 → ICOBase64 のアイコンをデコード、または画像を favicon.ico に変換 Base64 → AVIFBase64 の AVIF をデコード。対応ブラウザでは AVIF への変換も可能 Base64 → TIFFBase64 のスキャン画像を TIFF で保存、または画像を非圧縮 TIFF に変換

ファイルツール