Tüm kodlama araçları
Base64 ve diğer tüm yaygın ikiliden metne kodlamalar için tarayıcı tabanlı ücretsiz araçlar; ayrıca dönüştürücüler, görsel ve dosya araçları. Girdiğiniz hiçbir şey yüklenmez.
Base64 araçları
Base64 Kodlama ve Kod ÇözmeBase64 ve Base64URL biçiminde metin veya dosya kodlayın ve kodunu çözün
Base64 KodlamaMetni veya dosyaları karakter kümesi, dolgu ve satır kaydırma seçenekleriyle kodlayın
Base64 Kod ÇözmeBase64'ü metne veya onaltılık biçime çözün; karakter kümesi seçimi ve esnek girdi
Base64URLJWT, OAuth ve URL'ler için URL güvenli Base64 (RFC 4648 bölüm 5)
Base64 DoğrulayıcıBase64 ve Base64URL dizelerinde geçersiz karakter ve dolgu hatalarını kontrol edin
Base64'ten Hex'eBase64 hash, anahtar ve imzaları onaltılık biçime dönüştürün
Hex'ten Base64'eHex hash, anahtar ve parmak izlerini Base64'e dönüştürün
JWT ÇözücüJWT başlığını ve taleplerini çözün, süresini denetleyin, imzaları doğrulayın
Basic Auth OluşturucuHTTP Basic Authorization başlıkları oluşturun veya çözün
Data URI OluşturucuBase64 veya yüzde kodlamasıyla data: URI oluşturun ve inceleyin
Base-N kodlamaları
İkili (Base2)Bayt başına 8 bitle metinden ikili koda, ikili koddan metne
Sekizlik (Base8)Metinden sekizlik bayt değerlerine ve geri, 000 ile 377 arası
Ondalık (Base10)Metinden ondalık bayt değerlerine (ASCII kodları) ve geri
Onaltılık (Base16)Ayırıcı ve önek seçenekleriyle metinden hex'e, hex'ten metne
Base32RFC 4648 Base32, Base32hex, Crockford ve z-base-32
Base32hexSıralanabilir 0-9 A-V alfabesiyle RFC 4648 Base32
Crockford Base32Hataları affeden kod çözücüyle I, L, O ve U içermeyen okunabilir Base32
z-base-32Dolgusuz, insan odaklı küçük harfli Base32
Base36Rakamlar ve a-z: büyük/küçük harfe duyarsız büyük sayı kodlaması
Base45QR kodlar ve COVID sertifikaları için RFC 9285 Base45
Base58İsteğe bağlı Base58Check ile Bitcoin, Flickr ve Ripple Base58
Base58CheckBitcoin adreslerindeki gibi çift SHA-256 sağlama toplamlı Base58
Base62Kısa URL'ler ve kimlikler için yalnızca rakam ve harf
Base85Git ve Python'daki gibi RFC 1924 karakter kümesiyle Base85
Ascii85z kısaltması ve isteğe bağlı sınırlayıcılarla Adobe Ascii85
Z85Kaynak koddaki dizelerde güvenli ZeroMQ Base85 (RFC 32)
Base91Joachim Henke'nin kompakt ASCII kodlaması basE91
Uuencodebegin ve end satırlarıyla Unix-to-Unix kodlaması
XxencodeHarf ve rakamlardan oluşan alfabeye sahip uuencode varyantı
Dönüştürücüler
Tüm KodlamalarMetni aynı anda tüm biçimlerde kodlayın ve sonuçları karşılaştırın
Kodlama AlgılayıcıBilinmeyen kodlanmış bir dizeyi tanımlayın ve çözülmüş veriyi önizleyin
Kodlama DönüştürücüBase64, Base58, Base32, hex ve diğer kodlamalar arasında dönüştürme
Base58'den Hex'eBase58 adresleri, anahtarları ve hash değerlerini hex baytlarına çözün
Hex'ten Base58'eHex baytlarını, anahtarları ve hash değerlerini Base58 olarak kodlayın
Özel AlfabeHerhangi bir alfabeyle, büyük sayı veya bit grupları yöntemiyle kodlayın ve çözün
Sayı Tabanı DönüştürücüHer tam sayı için ikili, sekizlik, ondalık, hex, Base36 ve Base62
Görsel araçları
Görselden Base64'eHer görseli data URI, img etiketi, CSS veya Markdown olarak kodlayın
Base64'ten GörseleBase64 ve data URI'leri önizleyin, görsel dosyası olarak indirin
PNG'den Base64'eSaydamlığı korunan kayıpsız PNG, data:image/png Base64 olarak
JPG'den Base64'eKalite ayarıyla JPEG fotoğraflar, data:image/jpeg Base64 olarak
WebP'den Base64'eKompakt WebP görselleri, data:image/webp Base64 olarak
GIF'ten Base64'eSabit ve animasyonlu GIF'ler, data:image/gif Base64 olarak
SVG'den Base64'eSVG vektör grafikleri, data:image/svg+xml Base64 olarak
BMP'den Base64'eİsteğe bağlı PNG dönüştürmesiyle BMP bitmap'ler Base64 olarak
ICO'dan Base64'eFavicon'lar ve .ico dosyaları Base64 data URI olarak
AVIF'ten Base64'eAV1 ile sıkıştırılmış AVIF görselleri, data:image/avif Base64 olarak
TIFF'ten Base64'eTIFF taramaları ve baskı görselleri Base64 metni olarak
Base64'ten PNG'yeBase64 veya data:image/png dizelerini saydamlık dahil PNG olarak kaydedin
Base64'ten JPG'yeBase64'ü .jpg fotoğrafa çözün, dönüştürürken kaliteyi ayarlayın
Base64'ten WebP'yeBase64 WebP'yi çözün veya Base64 görselleri daha küçük WebP dosyalarına dönüştürün
Base64'ten GIF'eBase64 GIF'leri animasyonuyla kaydedin veya görselleri GIF'e dönüştürün
Base64'ten SVG'yeBase64 SVG simgelerini ve grafiklerini yeniden .svg dosyalarına çözün
Base64'ten BMP'yeBase64'ü .bmp'ye çözün veya görselleri 32 bit bitmap'e dönüştürün
Base64'ten ICO'yaBase64 simgeleri çözün veya Base64 görsellerden favicon.ico oluşturun
Base64'ten AVIF'eBase64 AVIF görselleri çözün veya destekleniyorsa AVIF'e dönüştürün
Base64'ten TIFF'eBase64 taramaları TIFF olarak kaydedin veya görselleri sıkıştırılmamış TIFF'e dönüştürün
Dosya araçları
Dosyadan Base64'e100 MB'a kadar her dosyayı ham Base64 veya data URI olarak kodlayın
Base64'ten DosyayaBase64'ü tür algılama ve önizlemeyle dosyaya dönüştürün
PDF'den Base64'ePDF'leri belge önizlemesiyle Base64 veya data URI olarak kodlayın
Base64'ten PDF'yeBase64'ü PDF'ye çözün, tarayıcıda görüntüleyin ve indirin
Sesten Base64'eMP3, WAV, OGG ve diğer ses dosyalarını Base64 veya data URI olarak kodlayın
Base64'ten SeseBase64'ü MP3, WAV, OGG, FLAC veya M4A'ya çözün ve dinleyin